You need to log in to create posts and topics.

Updating to PHP 7.3 throws me error Ubuntu 14.04 Server!!

$ apt-get install php7.3 is used to update the PHP to 7.3 version but it throws the following error.

# apt-get install php7.3

Reading package lists... Done

Building dependency tree

Reading state information... Done

E: Unable to locate package php7.3

E: Couldn't find any package by regex 'php7.3'

To Fix the above issue:

This is mainly due to the PHP going to stop the updates and support to this version. Ubuntu 14.04 is far outdated and it gonna end soon. All the supports and updates are given to Ubuntu 14.04 are going to end soon.

To overcome this error, You need to update your server to the latest version Ubuntu 18.04! Now, its the time to execute the following command:

apt-cache search php7.3 | grep "php7.3" | awk '{print $1}'

The above command will list you the available packages in the repository, select the packages to install the PHP 7.3 version in you Latest Ubuntu server!!